タグ: WT3020

10月6日LEDE(OpenWrt)、その他雑記

最近のLEDE(OpenWrt)関連とその他のざっくりまとめ。各題の枠の色は、は問題、は一部問題あり、は解決済みや単純な報告など。

  • LEDE on WT3020

    以前確保したPlanex VR500よりも前にeBayで注文し届いていたWT3020を、ようやくLEDE化した。

    のはいいものの、sysupgrade版ファームをブート中の起動方法選択メニューから投入してフラッシュを書き換え起動後、何故かLuCIにアクセスできない。IPアドレスもクライアントPCに振られておらず、LEDE上でLuCIを提供するuhttpdとDHCPを提供するdhcpdをシリアル接続のコンソールからpsコマンドで確認するも、既に起動済み。ifconfigを叩いたところ、明らかにインターフェース構成がおかしくなっており、これが問題の模様。
    LEDEのフォーク元であるOpenWrtのファームを投入したところ問題なく起動でき、また自分の使用しているLEDEレポジトリのフォーク元であるLEDE本家のレポジトリを使用したところ、この問題が発生しなかった。
    自分のLEDEフォークでは、WT3020と同じtargetであるramipsでは WHR-G300N, WT1520, VR500 の3機種に関連した変更を入れてあり、そのうちWHR-G300NとWT1520に関しては機種用dtsのみの変更のため、まずWT3020への影響はないものと判断。とりあえず、VR500のサポート追加のために使用した某氏のパッチでリバースをかけた後再度WT3020ファームをビルドし投入してみるも、再度この問題が発生。わけわかめ。
    後で “fix_wt3020” ブランチにて、WHR-G300NとWT1520に関連して入れた修正を戻して検証する。

  • WZR-900DHP(LEDE)

    Planex VR500を確保してからはしばらくそれを弄っていたものの、近日実家への引越しが迫っているためVPNやサーバ群用LAN構築のためWZR-900DHP用ファームの構成に着手。
    el1n氏のSoftEher VPN用OpenWrt関連ファイルのレポジトリを利用したほか、各サイトを参照しとりあえずファームのビルドと実機への投入、各種機能の正常動作の確認を完了。
    先月29日頃に実家に行き、既に実家に置いてあったオリジナルファームのWZR-900DHPを実家家庭内LANの無線を担っているWSR-1166DHP2へ接続させ、その下にLEDEのWZR-900DHPを設置。その後実家LAN内最上位のONU兼ルータのPR-S300HIで簡易DMZをWZR-900DHP(LEDE)のIPアドレスで指定。
    そしてその下にMinecraft鯖 / OpenWrt(LEDE)ビルド鯖のマシンを設置し、WZR-900DHP(LEDE)のファイアウォールをサーバ群LANから実家家庭内LANへセキュリティ的に問題が無いよう調整(サーバ群LANからWZR-900DHPのLuCI(http / 80)の遮断とか)。実用環境での設定は初めてで結構手間取った。
    今月1日頃に 大破.net をホストしているマシンを持って再び実家に行き、同様に設置作業を実施。大破.net 及び関連サイトのHTTP / 80はWZR-900DHP(LEDE)のLuCIと衝突するためポートフォワードが設定できず、現状HTTPS / 443のみ。WZR-900DHPを挟んで家庭内LANが上位、サーバ群LANが下位にあるためLuCIへのアクセスをサーバ群LANからは遮断し上位からのみとしていて、WZR-900DHPのLuCIとサーバ群LANのWebサーバへのアクセスが HTTP / 80で被ってしまう。どうするか思案中。
    SoftEther VPNは問題なく稼働中。

  • 録画鯖がTOKYO MXの録画を失敗する様になった(解決済み)

    前述のWebサーバを実家に移した際に、同時に録画鯖も移したものの、それ以降TOKYO MXの番組の録画に失敗する様になった。

    録画状況はTwitterにも投稿する様にしているが、ツイートに含まれるエラー内容は ”録画中に番組情報を確認できませんでした” 。最初は録画鯖にリモートデスクトップで接続したことによりスマートカードリーダが読めなくなったことが原因かと思ったが、色々試行した結果EDCBのチャンネルスキャンし直しで解決。残り2分弱程度でブレイブウィッチーズの第1話に間に合った。

広告